ZW3D CAD-CAM Logo  
   ZW3D Base
Home > ZW3D File Level > New File or Root Object
Article Title New File or Root Object
Invoked byFile > New

New FileThe New File/Object Form is used to create new ZW3D files and new root object within the active ZW3D file.

New parts, root sketches, and CAM plans will be assigned the linear units of measurement defined in the ZW3D Configuration Form.

 

  1. Select the file/object type (a default object type may already be selected).

  2. Select the object template or [no template] if desired.

  3. Pick OK to create the file/object and close the form or Cancel.


Forms and DialoguesType

  • New Part/Assembly
    New Part/AssemblyCreate a new file and part/assembly. An assembly is a part that has other parts (components) inserted into it. If a ZW3D file is currently active, this creates a new part in the active file.

 

ZW3D Tips & TechniquesFor assemblies, new parts can also be created using the Create/Edit Component or the Insert Component commands. A new part is added to the active file and is instanced as a component in the active part/assembly.


  • New Drawing Packet
    Open File (Ctrl+O)Create a new file and drawing packet. Drawing packets contain multiple drawing sheets. The ZW3D Object Manager is displayed for defining the first drawing sheet in the packet. If a ZW3D file is currently active, this creates a new drawing packet in the active file.

  • New Root Drawing Sheet
    Open File (Ctrl+O)Create a new file and root drawing sheet. A root drawing sheet is one that resides at the object level like a part. Drawing sheets can also reside in a Drawing Packet (see above). If a ZW3D file is currently active, this creates a new root drawing sheet in the active file.

  • New Standalone Sketch
    New Root SketchCreate a new file and standalone sketch. A standalone sketch is one that resides at the object level like a part or drawing packet. Sketches can also be created in a part to drive features. If a ZW3D file is currently active, this creates a new root sketch in the active file.



ZW3D Tips & TechniquesYou can create a root sketch from a part level sketch by copying it to the clipboard and then pasting it into the new root sketch.


  • New CAM Process Plan
    New CAM Process PlanCreate a new file and CAM process plan that can contain part components, CAM features and NC tool paths. If a ZW3D file is currently active, this creates a new plan in the active file.


  • New Standalone Equation
    New Root Equation SetCreate a new file and standalone equation. A standalone equation is one that resides at the object level like a part or drawing packet. Equations can also be created within a part or sketch. If a ZW3D file is currently active, this creates a new root equation set in the active file.

 

ZW3D Tips & TechniquesUse the ZW3D Object Manager to edit existing root equations. Equations can also be created and edited at the Part Level by selecting Tools > Equations... or at the Sketch Level by selecting Edit > Equations.... See Equations and Expressions for more information.

 

  • New ZW3D File with Multiple Objects
    New ZW3D File with Multiple ObjectsCreate a new file that will contain multiple objects types (e.g., parts, drawing packets, CAM process plans, etc.). When this type is selected, no initial object is created. The ZW3D Object Manager is displayed for defining the first object in the new file.

    This form can also be invoked for new files from the Tool Bar and with (Ctrl+N).

  • Open Existing File
    Open File (Ctrl+O)Use this icon to open an existing ZW3D file. This is the same as the File Open (Ctrl+O) command (see above).

 

Forms and DialoguesTemplate

Use this option to create a new part/assembly, drawing sheet, or CAM process plan based on an existing root object template (see figure at right) located in the Templates.Z3 file. Select one of the available templates or select [no template].

See Using Embedded Text Variables to learn how you can embed part attribute data in your drawing sheet title blocks.
 
 

Forms and DialoguesFile Information

  • Name
    Displays a system generated name for the new file and object by default. You can accept this name or enter a new one. For all file types except Multiple Objects, the file name and the object name will be the same. Refer to the Multiple Objects type listed above.

  • Description
    Enter a Description for the new file.  If you don't enter a name (see above), one is assigned for you, but if you want a description, you must enter one.  The Description becomes a Property of the ZW3D file.  You will see it in the  ZW3D Object Manager list and when you select File > Properties.

 

Forms and DialoguesOther Options

  • OK
    Accept the contents of the New File/Object Form and create the new file.

  • Cancel
    Cancel the command and close the New File/Object Form