ZW3D CAD-CAM Logo  
   ZW3D Base
Home > ZW3D Object Level > Insert New Root Object
Article Title Insert New Root Object

In this Article:

Insert New Root Object
Insert New Part/Assembly
Insert New Drawing Packet
Insert New Drawing Sheet
Insert New Sketch
Insert New CAM Plan
Insert New Equation Set
 
 

Insert New Root Object

Invoked by Insert Menu (Object Level)
Invoked by Root Object Browser (Object Level)

Use these commands from the Object Level to create and insert new Root Objects into the currently active file.  Root Objects include Parts/Assemblies, Drawing Packets, Drawing Sheets, Stand-a-lone Sketches, CAM Plans and Equation Sets.  When inserting a Root Object, the New File/Object Form shown below is displayed.  This form is also documented in the File Commands article.  Each command listed below is evoked from this form by selecting the corresponding icon.  Refer to each command below for more details.
 

Insert New Part/Assembly

Invoked by Insert Menu (Object Level)
Invoked by Root Object Browser (Object Level)

New Part/AssemblyUse this command to create a new Part or Assembly and then insert it into the currently active file.  The New File/Object Form is displayed.  Use it to define the new Part or Assembly.  Then select OK to activate the new object.
 

Insert New Drawing Packet

Invoked by Insert Menu (Object Level)
Invoked by Root Object Browser (Object Level)

Insert New Drawing PacketUse this command to create a new Drawing Packet and then insert it into the currently active file.  The New File/Object Form is displayed.  Use it to define the new Packet.  Then select OK to activate the new object.
 
 
 

Insert New Drawing Sheet

Invoked by Insert Menu (Object Level)
Invoked by Root Object Browser (Object Level)

Insert New Drawing SheetUse this command to create a new Drawing Sheet and then insert it into the currently active file.  The New File/Object Form is displayed.  Use it to define the new Sheet.  Then select OK to activate the new object.
 
 
 

Insert New Root Sketch

Invoked by Insert Menu (Object Level)
Invoked by Root Object Browser (Object Level)

Insert New Root SketchUse this command to create a new Root Sketch and then insert it into the currently active file.  Unlike a feature sketch that is embedded in a part's history.  A Root Sketch is a stand-alone object that can be used in multiple parts and/or assemblies.  The New File/Object Form is displayed.  Use it to define the new Root Sketch.  Then select OK to activate the new object.
 
 
 

Insert New CAM Plan

Invoked by Insert Menu (Object Level)
Invoked by Root Object Browser (Object Level)

Insert New CAM PlanUse this command to create a new CAM Plan and then insert it into the currently active file.  The New File/Object Form is displayed.  Use it to define the new CAM Plan.  Then select OK to activate the new object.
 
 
 

Insert New Equation Set

Invoked by Insert Menu (Object Level)
Invoked by Root Object Browser (Object Level)

New Root Equation SetUse this command to create a new Equation Set and then insert it into the currently active file.  The New File/Object Form is displayed.  Use it to define the new Equation Set.  Select OK to activate the new object.  The Equation Set Editor is then displayed so you can define the parameters of the new equation.