ZW3D CAD-CAM Logo  
   ZW3D Base
Home > ZW3D Object Level > ZW3D Object Manager
Article Title ZW3D Object Manager

In this Article:

 
 

ZW3D Object Manager

Invoked by Tools > ZW3D Manager (Object Level)

The ZW3D Object Manager lists all root objects (e.g., parts, drawing packets, drawing sheets, root sketches, CAM process plans, etc.) in the active ZW3D file. You can activate a root object for editing by double-left-clicking it from the list. You can right-click on an item in the list and select commands from the Object Editor pop-up menu. These and additional option buttons are provided along the right side of the browser. Each of these options are discussed below.

In the Preview section there are four modes in which you can work. These are: Off, Graphic, Attribute or Assembly. Off is the default mode for selecting root objects for editing. Graphic and Assembly are display modes and Attribute is an information mode. These modes are discussed in more detail below.
 
 
 

Forms and DialoguesRoot Object List

The list in the manager contains all root objects in the active ZW3D file and displays some information about the root objects, such as file type, file create time and modify time. Select an object from the list and then select an option or double-left-click an object to activate it for editing. You will then move to the ZW3D level appropriate for that object type (part, drawing packet, drawing sheet, CAM Level, etc.). If one of the Quick View modes are selected (see below), selecting an object will display additional information.
 
 

Forms and DialoguesSelection Options

  • Filter
    This filter is on the top of the manager. Use this option to filter the root object list to show only the root object of the selected type (About ZW3D Levels ).

  • Find
    Search the specific root objects. First enter the keywords in the Find field and select a required column, then press the "Enter" key to start searching.

  • Select all
    Selects all root objects in the list.


  • Unselect
    Unselect all root objects in the list.



 
 

Forms and DialoguesRight-click Menu

  • Edit
    Edit an objectActivates the select root object for editing.


  • Rename
    Rename an objectRenames the selected root object. Enter a new name in the text input field.


  • Delete
    Delete objectsDeletes the selected root object. You can also do this by selecting Edit > Delete from the pull down menu bar.

    Each deletion is recorded as separate undo/redo step. You can use undo from the Utility Tool Bar to get them back. The ZW3D Configuration Form to sets the maximum allowable undo/redo steps. You can also use the Delete Root Object command ( Edit > Delete)
CautionCAUTION: If you delete a root object, all entities contained in it (e.g., geometry, sketches, attributes, etc.) will be also be deleted.

 

  • Cut (to 3D Clipboard)
    Cut objects to clipboard Cut the selected root object. Use this command to move it to the 3D clipboard. You can then use the Paste from Clipboard (3D) command (see below) to paste it into any active ZW3D file. Until using the Paste command, this root object is deleted from the active file.

  • Copy (to 3D Clipboard)
    Copy objects to clipboardCopy the selected root object. Use this command to copy it to the 3D clipboard. You can then use the Paste command (see below) to paste it into any active ZW3D file. You can also use the Copy Root Object command ( Edit > Copy)

  • Paste (from 3D Clipboard)
    Paste objects from clipboardYou must first use the Cut or Copy command (see above) before using this command. This command pastes the contents of the 3D Clipboard into any active ZW3D file.


  • Separate
    Separate This option to provide a compatible way to separate a many-object-possessing file into different individual Z3 files.


    • Keep the objects in original file
      Check this option, the separation of the object not only to save in the new Z3 file, but also to kept in the original Z3 files. Otherwise, it only to keep in the new Z3 files.

    • When the file name is repeated
      When output filename conflicts in Save directory, specify one of three selections below to solve it.

    • Ask user
      The user is notified of the conflict and asked if he would like to continue with writing the file or not.

      Auto rename
      Rewrite out of date files.

      Skip
      Refuse to rewrite the existing file.
    • Save directory
      Specify the save directory of new Z3 file.


  • Regen
    Regen objectsThis option forces the regeneration of selected root object (i.e. part, CAM plan, sheet).


  • Rederive
    Rederive parts from seed partsIf the selected root object is a part that was derived from another part, this option will force it to be derived again (i.e., it will be recalculated from the part it was derived from). Changes to the parent part will be incorporated into the derived part.

  • Inquire
    Show object informationSelect this option to display information about the selected root object including Created Date, Last Modified and File size.
 
 
 
Forms and DialoguesPreview Mode
 
  • Off
    Select this option to disable preview mode.

  • Graphic
    Select this option to preview the graphics associated with a selected root object. The root object will be displayed in the preview window with the current viewing mode. Use the View Menu to set the viewing mode. Objects can still be activated for editing using the normal methods described above.
 
 
ZW3D Tips & Techniques
How to Quickly preview your Root Objects
If you want to preview all or many of your root objects, simply select an object and then use the <up arrow> and <down arrow> keys on your keyboard or use your Middle Mouse Wheel.  Each object will appear in the preview window!
 
 
  • Attribute
    Select this option to preview the part attributes of a selected part/assembly. You can use the displayed Part Attributes Form to derive a new root object or filter the  list of root objects.

  • Assembly
    Select this option to display the components information in Assembly Manager for the selected part/assembly.
 
 
 

Other Options

  • Export
    Export the information of selected root objects (highlighted) to *.xml or *.xls format. If nothing is selected, it will export all root objects.


  • Column view
    Set which items to show in the object manager.

 

Forms and DialoguesPreviewing Part Attributes

With Quick View set to Attribute the Part Attributes Form is displayed when a root object selected. It displays the part attributes for that root object. Note that the Derive new part and the Filter list by checked items buttons are now active on the Part Attributes Form.

You can create a family of parts based on key driving dimensions or variables or filter the root object list based on checked attributes. Refer to the Part Attributes Form for assigning part attributes, driving dimensions or variables.
 
 

NotesNotes

  1. Using the (Ctrl) and (Shift) Keys for Selection - When you select an item from the list, the item will highlight indicating that it has been selected. You can use the (Shift) key to select blocks of items. (Shift)+(Left-click) will select all items between the picked item and the first item on the active pick list -- all other items are unpicked. You can use (Ctrl)+(Left-click) to unpick an item from the active pick list.